猫言猫语

吾輩は猫である...

您尚未登入。

公告

al Fine?
......

#1 2015-04-07 00:52:07

leaves
时空管理局
注册时间: 2013-07-07
帖子: 20

记录:解决LNMP1.1安装typecho后404问题的方法

今天把一个WordPress站点换成typecho,安装过程很顺利,也提示安装成功。
但是打开首页的文章页面或者关于页面,或者在后台界面输入账号密码点击登录,都报404 Not Found错误。
网上找了一些方法,比较复杂,先要改nginx里的站点配置文件,然后还要改pathinfo.conf配置文件,关键是改了还没有效果!
后来根据某篇文章的启发,出现404是因为typecho需要pathinfo,然后看了下站点的nginx配置文件,发现添加vhost事LNMP自动生成的nginx配置文件里,下面这句已经提醒怎么修改了:
# comment try_files $uri =404; to enable pathinfo
意思是:如果想要启用pathinfo,需要注释掉“try_files $uri =404;”这行代码。
所以,LNMP1.1安装typecho后404问题解决办法就是:
在/usr/local/nginx/conf/vhost/下找到你的typecho站点配置文件(文件名类似xxxxx.conf),然后:
1、确保有“include typecho.conf;”这么一行,并且没有被“#”号注释;
2、用“#”号注释“try_files $uri =404;”这一行;
3、取消“#include pathinfo.conf;”这一行前面的的“#”号;
修改正确的话,typecho站点conf配置文件看起来如下:
include typecho.conf; 
#error_page   404   /404.html; 
location ~ [^/]\.php(/|$) 
    { 
        # comment try_files $uri =404; to enable pathinfo 
        #try_files $uri =404; 
        fastcgi_pass  unix:/tmp/php-cgi.sock; 
        fastcgi_index index.php; 
        include fastcgi.conf; 
        include pathinfo.conf; 
    } 
4、重启nginx或lnmp:
# service nginx restart 
或者重启lnmp也行:
# /root/lnmp restart 
5、打开你的typecho站点文章页或者登录管理页面,验证问题是不是已经解决了!
注意:
这个typecho 404问题的解决方法,只敢保证可以解决军哥的LNMP1.1一键安装包环境安装typecho后出现404问题,其他的情况,不敢确定。


-----------------------
涉及目录
vi /usr/local/php/etc/php.ini
vi /usr/local/nginx/conf/nginx.conf

重启
service nginx restart
/etc/init.d/php-fpm restart


-------------------------------
原地址:http://www.yimiju.com/articles/593.html

离线

页脚